Nov 272010
 

We had reported yesterday that iPhone Dev Team plans to release the eagerly awaited unlock for iPhone 3GS and iPhone 3G for iOS 4.2.1 on Sunday.

However, it is not clear if the updated version of Ultrasn0w will unlock baseband 05.15.04 that was shipped with iOS 4.2.1.

But we have some good news for users who have accidentally updated their iPhone 3GS or iPhone 3G with iOS 4.2.1 and updated the baseband to 05.15.04.

MuscleNerd has just confirmed that the updated Ultrasn0w will also unlock baseband 05.15.04.

ssstephD: @MuscleNerd will the new ultrasn0w unlock be able to unl0ck baseband 5.15.04? made the big mistake of upgrading it =/ !

MuscleNerd: @ssstephD it covers 05.15.04 too — but yeah, really need to stay vigilant about not updating :(

So users who have accidentally updated their iPhone 3GS or iPhone 3G to iOS 4.2.1 (not using the official iPhone carrier SIM) should be relieved as they will soon be able to use their iPhone.

The updated Ultrasn0w should also work on iOS 4.1 or earlier firmwares.

iPhone Dev team had mentioned earlier that the unlocking solution for iPhone 4 users will need more effort and were not in a position to provide any further information.

As always, we’ll let you know as soon as the updated Ultrasn0w is released so stay tuned here at Theiphonenerd or follow us on Twitter, facebook or subscribe to our RSS feed.

[via MuscleNerd]

Sorry, the comment form is closed at this time.